User forums now online! Please see the latest post in the Announcements forum for more information.

Author Topic: Bad colors in animated gif  (Read 969 times)

0 Members and 1 Guest are viewing this topic.

aslaksen

  • Full Member
  • ***
  • Posts: 89
    • View Profile
Bad colors in animated gif
« on: 2021-01-07 09:57:49 »
I have problems with many animated gifs. Sometimes they only show some of the images correctly, while all the images in between them have wrong colors. In this example, everything plays fine, but if I stop, and then try to move image by image using alt+page up/down, the colors are wrong. I think it has something to do with transparent background. Anything I can do with the image of ThumbsPlus to solve such problems?

Thanks!

Helmer

Daan van Rooijen

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 892
    • View Profile
Re: Bad colors in animated gif
« Reply #1 on: 2021-01-07 13:03:48 »
I suspect that your sample file is corrupt or not fully compliant with the GIF89a specs.  When I use either ThumbsPlus or Irfanview to split it into frames, I get very strange results (frames with different dimensions, different parts of the image, et cetera). When I try to load it into JASC's Animation Shop or into Total Commander's viewer, they even crash.

The default background color for transparent areas is set in Options | File Loading | GIF.
« Last Edit: 2021-01-07 13:10:42 by Daan van Rooijen »
I'm volunteering as a moderator - I do not work for Cerious Software, Inc.