User forums now online! Please see the latest post in the Announcements forum for more information.

Author Topic: MS SQL Server ODBC connection - is there username? *Solved*  (Read 1307 times)

0 Members and 1 Guest are viewing this topic.


  • Member
  • **
  • Posts: 8
    • View Profile
I've successfully connected TB10 to my SQL Server 2017, and it creates the data, but how can I access the data outside of TB10?

I'm doing some website-to-image reconciliations, and having the TB database available natively via an system-level ODBC connector is great (having imported copies of it previously), but having access to the latest "LIVE" data would be great. I created the table using the "Thumbs9_mssql.sql" script and successfully connected TB10 to it.

I can see the database show up in my MS SQL Server Management studio, I can expand it to see the table names, but I CANNOT expand any table to show data. All queries come back as "successful", but with zero rows! I've tried other ODBC clients too, with no success. The "Properties / Permissions" tab doesn't show anything weird, and they're the same as the other 2 databases I have running on the server at the same time (one being the imported TB database, the other the webserver database). The only think I can think of is I must be missing some sort of username permission?

The only sure-fire way to access the data is through TB10 application. Why can't I connect to this dataset via ODBC with any other client?

edit: I did find mention of the alias for dbo called "ThumbsUser" in the guide7.pdf. No luck. Plus, couldn't find reference to that in the setup sql script. Checked the "Security\Users\dbo" properties, and they match the same properties I use in the other 2 databases..

edit2: Found that I *could* open the "ThumbsPlusDatabase" table... whichk reports exacty 0 thumbnail _files. BUH?!? TB10 says (under "Thumbnail Database Statistics" there are over 141,585 Thumbnail records. Somehow, these seem to be looking at two different databases? Using the same 32-bit system ODBC connector settings? Weird. The digging continues...

edit3: FOUND IT. I must have done something wrong during configuration, as it dumped all the TB10 tables under the MASTER database. Grrr. Ok, now how to fix it without having to regen 3 hours of indexing.  >:(

« Last Edit: 2019-08-17 21:17:29 by hockeyrink »