User forums now online! Please see the latest post in the Announcements forum for more information.

Author Topic: GHOSTSCRIPT v2.7 error: Unable to create Ghostscript instance (-100)  (Read 223 times)

0 Members and 1 Guest are viewing this topic.

Laura Shook

  • Administrator
  • Sr. Member
  • *****
  • Posts: 138
    • View Profile
This error message was reported by several ThumbsPlus users so I downloaded the newest Ghostscript (v2.7) and duplicated the problem. Something has changed in the new Ghostscript code, causing these errors when attempting to thumbnail and view .pdf files. (This also pertains to ps, eps and ai files set up to load using the Ghostscript plug-in.)

The solution is use the dll from any earlier version of the Ghostscript app. I am successfully using ThumbsPlus and the Ghostscript Plug-in with all previous 32 bit versions of the gsdll32.dll

You may already have this on your system, but if not, you can download any earlier version than Ghostscript 9.27 (by scrolling past 2.7) here:
https://github.com/ArtifexSoftware/ghostpdl-downloads/releases

You don't even have to remove the newer version, just choose the gsdl32.dll from the 9.20 - 9.26 install (in the Ghostscript plug-in options) as shown in the attached image.

We will, of course, be testing and solving the problem between the ThumbsPlus Ghostscript plug-in and Ghostscript v9.27 for the next release.

ThumbsPlus.com
« Last Edit: 2019-06-21 14:53:12 by Laura Shook »