User forums now online! Please see the latest post in the Announcements forum for more information.

Author Topic: Black thumbnails of video files (mpg) solved!  (Read 996 times)

0 Members and 1 Guest are viewing this topic.

aslaksen

  • Full Member
  • ***
  • Posts: 89
    • View Profile
Black thumbnails of video files (mpg) solved!
« on: 2016-09-03 18:15:25 »
I have a lot of problems thumbnailing video files. Some problems can be solved by deleting the thumbnails (Shift-Del) and then using Ins instead of F3. However, for many problem, it seems that you have to tweak your splitters filters/codecs. I use K-Lite's Full version, which has ffdshow.

Some of my mpg files only had black thumbnails. (It seems to be the ones with MPEG-2 Program Stream instead of Transport Stream.) I opened the Codec Tweak Tool and clicked on Codec and Filter Management: Preferred splitters. Scroll downed the left column (32-bit) until I saw .MPG. Then selected LAV instead of Microsoft. This solved my problem!

However, I don't really understand what's going on, because if click on Configuration: DirectShow Filters: Video Decoders: LAV Video decoder: Formats, I see that MPEG-2 is unchecked, so I really don't understand if I'm using LAV or not. If I click on Configuration: DirectShow Filters: Video Decoders: ffdshow video decoder (x86), I see that libavcodec is selected.

Anyway, it solved my black thumbnails.