Author Topic: Move TNs to file - issue  (Read 8198 times)

0 Members and 1 Guest are viewing this topic.


  • Member
  • **
  • Posts: 3
    • View Profile
Move TNs to file - issue
« on: 2019-05-09 16:23:26 »
I executed the procedure under FAQ "Database is full error/ I can't create new thumbnails" to move thumbnails to files. The database is old... created under TP7 iirc, upgraded over time, keeps bumping into the 2TB limit. After the procedure and TP restart, all TNs showed up as black squares. Re-creating TNs caused them to go into the DB (evidenced by DB growing), not the file system. I tried a new DB with "TNs in files" from creation time, and that worked AOK. I tried a new DB with TNs in the DB, created a hundred or so TNs, ran the "move TNs fo files" option, and same result as with the old DB - black square TNs.

Comparing the DBs, I noticed that the "converted" ones did not have the row "thumbnail_files,1" in table ThumbsPlusDatabase. To be more accurate, the old DB was missing that row altogether, the newer converted DB had it set to 0. After fixing that, both the smaller new test DB and the large old DB are working fine, and accessing the TNs in the file system.

TP 10 sp2[4013]
« Last Edit: 2019-05-09 16:26:31 by browncoat125 »

Laura Shook

  • Administrator
  • Sr. Member
  • *****
  • Posts: 143
    • View Profile
Re: Move TNs to file - issue
« Reply #1 on: 2019-05-15 13:41:54 »
You ran into a problem that was fixed in build 4015. You fixed the problem yourself, but the work around would have been to just run the "thumbnails to files" process once more.

Kind regards,