Author Topic: all my .PNG files are black  (Read 4411 times)

0 Members and 1 Guest are viewing this topic.

Connie

  • Full Member
  • ***
  • Posts: 31
    • View Profile
all my .PNG files are black
« on: 2016-11-14 22:13:40 »
The Help file says that TP can display PNG files but I'm only seeing black in both the Preview window and in the thumbnail list.  

When I double click the PNG file, the View window is all black.  If I look at the file in my file list, it shows as a graphic, or if I edit the file in Irfanview, it shows as a graphic.

I'm using latest TP, in Windows 7.

I searched the Forum for PNG, but didn't find any display issues.

What do I need to do to be able to see these?  Is there a setting I'm missing?

TIA, Connie

Daan van Rooijen

  • Administrator
  • Sr. Member
  • *****
  • Posts: 938
    • View Profile
all my .PNG files are black
« Reply #1 on: 2016-11-15 06:50:26 »
> The Help file says that TP can display PNG files but I'm only seeing black in both the Preview window and in the thumbnail list.

When you right-click on a PNG file and choose 'Configure File Type', is the value for 'Load file using' set to 'Internal'? (if not, I think that would fix it).

When you go to Options | Viewing | Tab:Editing, and you set 'Alpha Channel Display Options' to Checkerboard, does that fix it?

When you open some random JPG file and use File | Save As to convert it to PNG, and then you open that PNG version of the same image, does it still show as all black?

Feel free to email me one of those PNG files if none of this helps, so I can see how it behaves here (email under the little envelope next to my name).
I'm volunteering as a moderator - I do not work for Cerious Software, Inc.

Connie

  • Full Member
  • ***
  • Posts: 31
    • View Profile
all my .PNG files are black
« Reply #2 on: 2016-11-21 09:53:52 »
> > The Help file says that TP can display PNG files but I'm only seeing black in both the Preview window and in the thumbnail list.

UPDATE:  Not ALL of my PNG files are black.  (And that confuses me more)

> When you right-click on a PNG file and choose 'Configure File Type', is the value for 'Load file using' set to 'Internal'? (if not, I think that would fix it).

It was set to .PDF (not sure why, but I may have changed it myself to try & figure out why I was seeing black).  So, I changed it to 'Internal' but that didn't fix it. Still black.

> When you go to Options | Viewing | Tab:Editing, and you set 'Alpha Channel Display Options' to Checkerboard, does that fix it?

Alpha Channel Display Options was already set to Checkerboard.

> When you open some random JPG file and use File | Save As to convert it to PNG, and then you open that PNG version of the same image, does it still show as all black?

I saved a JPG as PNG, it displays normally. However, when I double-click on the PNG file, it doesn't open in the Thumbnail viewer. I checked the File Type Configuration for .PNG and it shows as "Equivalent to Type: None", Category None, Class blank.  That seems odd to me. I expected to see 'equivalent to png', not None.

> Feel free to email me one of those PNG files if none of this helps, so I can see how it behaves here (email under the little envelope next to my name).

Thanks again, Daan.  I'm so easily confused. :)

Daan van Rooijen

  • Administrator
  • Sr. Member
  • *****
  • Posts: 938
    • View Profile
all my .PNG files are black
« Reply #3 on: 2016-11-21 11:32:04 »
Hi Connie,

> > When you right-click on a PNG file and choose 'Configure File Type', is the value for 'Load file using' set to 'Internal'? (if not, I think that would fix it).
>
> It was set to .PDF (not sure why, but I may have changed it myself to try & figure out why I was seeing black).  So, I changed it to 'Internal' but that didn't fix it.

'Load file using' can't have been '.PDF'- that is not an option there. Maybe you had inadvertently right-clicked on a .PDF file instead of a .PNG file?

Please give this another try: Right-click on one of those black .PNG files, choose 'Configure Type',  and then verify that the values shown are exactly like this (and adjust them if they are not):



Press OK to save these settings and to return to the thumbnail listing. Then select that black .PNG file again, and press the 'F3' key to refresh its thumbnail. If it still shows as black, chances are that something is wrong or unusual with those PNG files, and I'd be happy to look further into it if you e-mail me one.
I'm volunteering as a moderator - I do not work for Cerious Software, Inc.

Daan van Rooijen

  • Administrator
  • Sr. Member
  • *****
  • Posts: 938
    • View Profile
all my .PNG files are black
« Reply #4 on: 2016-11-22 18:49:45 »
Hi again Connie,

I received your e-mail with the image sample, and it looks like ThumbsPlus is just not interpreting the image correctly. It shows as all black, as you've also noted. I've also tried with a few different programs. Irfanview 4.40 also shows it as all black, but Imagine shows it correctly as a black outline against the checkered backdrop of the alpha channel.

Your image is in 8-bit greyscale PNG format. There's nothing wrong with that, but it's not a very common format. When I change its color space to 24 bit RGB, ThumbsPlus shows it correctly.

I have forwarded the image to Cerious in hopes that they'll fix this in a future release.

So, at this point, I can only offer you the work-around of promoting the images' colorspace to 24b, but I'm not sure if you'll want to do that, because you may have other programs that require the image to remain in 8b greyscale format.. please decide for yourself.

If you do want to promote a single image to 24b, here's how to do it:

    [*]Open it in the viewer
    [*]Apply Image | Mode | 24-bit RGB
    [*]Use Save or Save As to save the image in PNG format, then close the viewer.
    [*]When you next thumbnail or open the saved copy, it will show correctly.[/list]

    To promote multiple images to 24b:

      [*]Select the images (thumbnails) in ThumbPlus
      [*]Go to Image | Batch Process. On the Input Files tab, set 'Files to process' to 'Selected files'. On the Batch Steps tab, use Add | Image | Color Depth and set Desired Color Mode to RGB (24-bit). On the Output Details tab, use PNG as the output format. If you do not want your original files to be overwritten, you can add a suffix (e.g. '-24b') to the filenames that the converted versions will be written to, or you can specify a different output folder.
      [*]When you press OK, the batch process will run. The output files should look and thumbnail correctly.[/list]

      Regards,

      -Daan-
      I'm volunteering as a moderator - I do not work for Cerious Software, Inc.

      Connie

      • Full Member
      • ***
      • Posts: 31
        • View Profile
      all my .PNG files are black
      « Reply #5 on: 2016-11-24 07:32:54 »
      Daan, again....THANK YOU...for your digging into this and posting the step-by-step instructions.  I really appreciate it and I've saved your instructions.  So helpful.  

      Regards, Connie